Pagina 1 di 1
 
 

Messaggio Problema Con Rss Feed

#1  zampata Sabato, 01 Ottobre 2011, 12:49

ho un problema con gli rss .. mi da questo errore: error on line 1 at column 6: XML declaration allowed only at the start of the document
error on line 1 at column 44: Encoding error

gli rss li trovate qui: http://www.nordestmeteo.it/rss.php?f=1 http://www.nordestmeteo.it/rss.php

ho guardato in giro, ma non so cosa cambiare

grazie a chi mi risponderà   
 





 
avatar
 zampata Sesso: Uomo
Visitatore
Visitatore
 
Età: 41
Registrato: Settembre 2009
Messaggi: 36
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#2  TopoMotoV3X Sabato, 01 Ottobre 2011, 15:26

Successe anche a me, avevo una una scritta in lingua spagnola in firma, e non venivano riconosciuti i caratteri...
controllando i tuoi feeds ho capito che l'errore sta in Questo forum e può essere nei post scritti dal 30 settembre in giù, fai un controllo negli ultimi post scritti in quel forum.

Saluti.
 




Versione di IP: 1.3.0.53b

Server: Linux

____________
risolto
Guida ad Icy Phoenix
Mobile Modding Community
 
avatar
italia.png TopoMotoV3X Sesso: Uomo
Staff
Staff
AutoGatto è gay
 
Età: 43
Registrato: Agosto 2007
Residenza: Cagliari
Messaggi: 893
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#3  Andrea75 Sabato, 01 Ottobre 2011, 17:42

In realtà il problema sembra essere nella prima riga del feed:

http://validator.w3.org/feed/check....eo.it%2Frss.php

Controlla che nel file /templates/default/rss_body.tpl il testo della prima riga sia posizionato all'inizio, o nel dubbio, ricaricalo.

P.S.: per controllare i feed usate lo strumento qui sopra. Gli errori vi verranno mostrati in modo dettagliato e con le possibili soluzioni.
 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#4  TopoMotoV3X Sabato, 01 Ottobre 2011, 18:44

Ma se fosse il tpl non darebbe l'errore su tutte le pagine? ... perche io questo pomeriggio controllando ho notato l'errore sui feeds del forum id 3, il 2 e 1 li visualizzavo correttamente,  ora invece c'è su tutti e 3... sul 10 però no... non potrebbe essere un utente che ha un carattere non riconosciuto in firma?
 




Versione di IP: 1.3.0.53b

Server: Linux

____________
risolto
Guida ad Icy Phoenix
Mobile Modding Community
 
avatar
italia.png TopoMotoV3X Sesso: Uomo
Staff
Staff
AutoGatto è gay
 
Età: 43
Registrato: Agosto 2007
Residenza: Cagliari
Messaggi: 893
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#5  Andrea75 Sabato, 01 Ottobre 2011, 19:55

TopoMotoV3X ha scritto: [Visualizza Messaggio]
Ma se fosse il tpl non darebbe l'errore su tutte le pagine? ... perche io questo pomeriggio controllando ho notato l'errore sui feeds del forum id 3, il 2 e 1 li visualizzavo correttamente,  ora invece c'è su tutti e 3... sul 10 però no... non potrebbe essere un utente che ha un carattere non riconosciuto in firma?


Boh... io anche sul 10 ( http://www.nordestmeteo.it/rss.php?f=10 ) vedo questo:

This page contains the following errors:

error on line 1 at column 6: XML declaration allowed only at the start of the document
Below is a rendering of the page up to the first error.

 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#6  TopoMotoV3X Sabato, 01 Ottobre 2011, 20:04

io vedo questo:

 2011_10_01_200418
 




Versione di IP: 1.3.0.53b

Server: Linux

____________
risolto
Guida ad Icy Phoenix
Mobile Modding Community
 
avatar
italia.png TopoMotoV3X Sesso: Uomo
Staff
Staff
AutoGatto è gay
 
Età: 43
Registrato: Agosto 2007
Residenza: Cagliari
Messaggi: 893
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#7  Andrea75 Sabato, 01 Ottobre 2011, 20:45

Firefox contro Chrome... Cmq ci sono problemi di fondo... è evidente dai simboli del CDATA riportati in mezzo al testo....
 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#8  zampata Sabato, 01 Ottobre 2011, 20:57

il file /templates/default/rss_body.tpl è apposto .. la declaration è all'inizio

ma è starno .. con chrome subito mi da errore ... poi se aggiorno lo apre, ma ci sono evidenti errori

qualche altra idea?
 





 
avatar
 zampata Sesso: Uomo
Visitatore
Visitatore
 
Età: 41
Registrato: Settembre 2009
Messaggi: 36
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#9  Andrea75 Domenica, 02 Ottobre 2011, 09:39

Potrebbe essere anche un problema di codifica... potresti provare a modificarla da ISO-8859-1 a UTF8 e vedere se cambia qualcosa....
 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#10  zampata Domenica, 02 Ottobre 2011, 20:39

Andrea75 ha scritto: [Visualizza Messaggio]
Potrebbe essere anche un problema di codifica... potresti provare a modificarla da ISO-8859-1 a UTF8 e vedere se cambia qualcosa....


scusa la mia ignoranza... ma in che file devo modificare?
 





 
avatar
 zampata Sesso: Uomo
Visitatore
Visitatore
 
Età: 41
Registrato: Settembre 2009
Messaggi: 36
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#11  TopoMotoV3X Lunedì, 03 Ottobre 2011, 00:08

Spero di non dire fesserie...

In rss_body.tpl cambia la prima riga con questo:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

 




Versione di IP: 1.3.0.53b

Server: Linux

____________
risolto
Guida ad Icy Phoenix
Mobile Modding Community
 
Ultima modifica di TopoMotoV3X il Lunedì, 03 Ottobre 2011, 00:09, modificato 1 volta in totale 
avatar
italia.png TopoMotoV3X Sesso: Uomo
Staff
Staff
AutoGatto è gay
 
Età: 43
Registrato: Agosto 2007
Residenza: Cagliari
Messaggi: 893
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#12  Andrea75 Lunedì, 03 Ottobre 2011, 08:10

TopoMotoV3X ha scritto: [Visualizza Messaggio]
Spero di non dire fesserie...

In rss_body.tpl cambia la prima riga con questo:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />


Eehheheheh... non è una fesseria, ma in realtà nel file .tpl c'è la variabile, che va modificata in language/lang_italian/lang_main_settings.php

Quindi dovrai cambiare:
$lang['ENCODING'] = 'ISO-8859-1';


in
$lang['ENCODING'] = 'UTF-8';

 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#13  zampata Lunedì, 03 Ottobre 2011, 08:53

purtroppo non funziona
 





 
avatar
 zampata Sesso: Uomo
Visitatore
Visitatore
 
Età: 41
Registrato: Settembre 2009
Messaggi: 36
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#14  Andrea75 Lunedì, 03 Ottobre 2011, 10:16

Probabilmente perché la codifica del resto del sito continua ad essere in ISO-8859-1.

Con la versione attuale mi ricordo anche io di aver avuto qualche problema con gli RSS... vuoi per le lettere accentate, i simboli... un grosso aiuto ce l'ho avuto aggiornando alle attuali versioni di sviluppo, che convertono tutto in UTF8.
Di più purtroppo non saprei dirti... gli RSS sono una bestiaccia...
 




Versione di IP: 2.0.0.86

Server: Linux

____________
My Icy forum: www.lineameteo.it
Staff Member @ Icy Phoenix.it & Icy Phoenix.com
 
avatar
italia.png Andrea75 Sesso: Uomo
Amministratore
Amministratore
bel tempo con possibili rovesci
 
Età: 42
Registrato: Mag 2007
Residenza: Perugia
Messaggi: 3984
  • Torna in cima Vai a fondo pagina
 

Messaggio Re: Problema Con Rss Feed

#15  zampata Lunedì, 03 Ottobre 2011, 12:17

Andrea75 ha scritto: [Visualizza Messaggio]
Probabilmente perché la codifica del resto del sito continua ad essere in ISO-8859-1.

Con la versione attuale mi ricordo anche io di aver avuto qualche problema con gli RSS... vuoi per le lettere accentate, i simboli... un grosso aiuto ce l'ho avuto aggiornando alle attuali versioni di sviluppo, che convertono tutto in UTF8.
Di più purtroppo non saprei dirti... gli RSS sono una bestiaccia...


gentilissimo! grazie cmq
 





 
avatar
 zampata Sesso: Uomo
Visitatore
Visitatore
 
Età: 41
Registrato: Settembre 2009
Messaggi: 36
  • Torna in cima Vai a fondo pagina
 


NascondiQuesto argomento è stato utile?
Condividi Argomento
Segnala via email Facebook Twitter Windows Live Favorites MySpace del.icio.us Digg SlashDot google.com LinkedIn StumbleUpon Blogmarks Diigo reddit.com Blinklist co.mments.com
technorati.com DIGG ITA linkagogo.com meneame.net netscape.com newsvine.com yahoo.com Fai Informazione Ok Notizie Segnalo Bookmark IT fark.com feedmelinks.com spurl.net
Inserisci un link per questo argomento
URL
BBCode
HTML
NascondiArgomenti Simili
Argomento Autore Forum Risposte Ultimo Messaggio
No Nuovi Messaggi Feed XML RaThSi Archivio 'Supporto Generale' 16 Sabato, 03 Novembre 2007, 10:55 Leggi gli ultimi Messaggi
Ryan
No Nuovi Messaggi PAgina RSS Feed Non Visualizzata FedericoBiccheddu Archivio 'Supporto Generale' 8 Sabato, 12 Aprile 2008, 17:45 Leggi gli ultimi Messaggi
danmartin
No Nuovi Messaggi Feed RSS napless Archivio 'Supporto Generale' 4 Lunedì, 05 Gennaio 2009, 16:45 Leggi gli ultimi Messaggi
napless
No Nuovi Messaggi Rss Feed Homepage zirosky Archivio 'Supporto Generale' 2 Lunedì, 12 Gennaio 2009, 11:48 Leggi gli ultimi Messaggi
zirosky
No Nuovi Messaggi Creare Feed RSS è Possibile? zampata Archivio 'Supporto Generale' 15 Venerdì, 04 Settembre 2009, 11:50 Leggi gli ultimi Messaggi
buldo

Pagina 1 di 1